re = /(\d{1,2}:\d{2}[ap]m\s–\s\d{1,2}:\d{2}[ap]m)(\D*(?:\d(?!\d?:\d{2}[ap]m\s)\D*)*)/
str = '1:19pm – 10:33pm ate tacos 10:35pm – 11:38pm 12:40am – 1:24am took a nap'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end