package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0-[0-9]|1-[1-9]|2-[2-9]|3-[3-9]|4-[4-9]|5-[5-9]|6-[6-9]|7-[7-9]|8-[8-9]|9-9`)
var str = `0-8
4-2
9-9
5-5
8-3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}