re = /0-[0-9]|1-[1-9]|2-[2-9]|3-[3-9]|4-[4-9]|5-[5-9]|6-[6-9]|7-[7-9]|8-[8-9]|9-9/m
str = '0-8
4-2
9-9
5-5
8-3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end