re = /imageBigViewURL=\[(.+?)\];/mi
str = '<script type="text/javascript">
if(!window.runParams) {
window.runParams = {};
}
window.runParams.imageServer="http://i00.i.aliimg.com";
window.runParams.imageDetailPageURL="//www.aliexpress.com/item-img/2015-Winter-Beanies-Solid-Color-Hat-Unisex-Plain-Warm-Soft-Beanie-Skull-Knit-Cap-Hats-Knitted/32462312884.html";
window.runParams.imageBigViewURL=[
"http://g02.a.alicdn.com/kf/HTB1JJG8JpXXXXb7XFXXq6xXFXXXs/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1frm7JpXXXXbFXFXXq6xXFXXXo/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1BsaSJpXXXXa3aXXXq6xXFXXX9/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1tUYfJpXXXXbVXXXXq6xXFXXXc/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g04.a.alicdn.com/kf/HTB1LRSUJpXXXXaeaXXXq6xXFXXXr/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1VSi8JpXXXXbUXFXXq6xXFXXXU/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg"
];
window.runParams.mainBigPic = "http://g02.a.alicdn.com/kf/HTB1JJG8JpXXXXb7XFXXq6xXFXXXs/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg";
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end