#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^frame=(?'frame'\s*[\d]+\n)fps=(?'fps'\s*.*?\n).+bitrate=(?'bitrate'\s*.*?)k.+out_time_ms=(?'time'\s*.*?)\n.+speed=(?'speed'\s*.*?)\n"
Local $sString = "frame=160" & @CRLF & _
"fps=0.00" & @CRLF & _
"stream_0_0_q=-1.0" & @CRLF & _
"bitrate=1431.0kbits/s" & @CRLF & _
"total_size=957885" & @CRLF & _
"out_time_us=5355167" & @CRLF & _
"out_time_ms=5355167" & @CRLF & _
"out_time=00:00:05.355167" & @CRLF & _
"dup_frames=0" & @CRLF & _
"drop_frames=0" & @CRLF & _
"speed=27.3x" & @CRLF & _
"progress=end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")