import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^frame=(?'frame'\\s*[\\d]+\\n)fps=(?'fps'\\s*.*?\\n).+bitrate=(?'bitrate'\\s*.*?)k.+out_time_ms=(?'time'\\s*.*?)\\n.+speed=(?'speed'\\s*.*?)\\n";
final String string = "frame=160\n"
+ "fps=0.00\n"
+ "stream_0_0_q=-1.0\n"
+ "bitrate=1431.0kbits/s\n"
+ "total_size=957885\n"
+ "out_time_us=5355167\n"
+ "out_time_ms=5355167\n"
+ "out_time=00:00:05.355167\n"
+ "dup_frames=0\n"
+ "drop_frames=0\n"
+ "speed=27.3x\n"
+ "progress=end\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}