package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b[A-Z]?[a-z]+\b)+`)
var str = `Bimkingo Clasico Prom 135g LON 49835 Gansito ME 5p 250g MTA MLA 49860 Wonder`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}