re = /(\b[A-Z]?[a-z]+\b)+/
str = 'Bimkingo Clasico Prom 135g LON 49835 Gansito ME 5p 250g MTA MLA 49860 Wonder'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end