use strict;
my $str = 'Prayer: Lord. Have mercy on.';
my $regex = qr/^[^:]*:\s*[^.]+\.\s*([^.]+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";