// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^: ]+:[^:]+:([^:]+):[^:]+:[^:]+)(:[^: ]+)").unwrap();
let string = "almada-institute.com:25:info@almada-institute.com:info12345:\"hello\":nossl in-graph.com:25:info@in-graph.com:info123456789:\"hello\":nossl get-herbals.net:25:info@get-herbals.net:info321:\"hello\":nossl
";
let substitution = "\\1<\\2>\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}