import Foundation
let pattern = #"([^: ]+:[^:]+:([^:]+):[^:]+:[^:]+)(:[^: ]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
almada-institute.com:25:info@almada-institute.com:info12345:"hello":nossl in-graph.com:25:info@in-graph.com:info123456789:"hello":nossl get-herbals.net:25:info@get-herbals.net:info321:"hello":nossl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1<\2>\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)