import re
regex = re.compile(r"\\(?:0_ASW|10_BSW)\\(\w+)", flags=re.MULTILINE)
test_str = ("C:\\MyPath\\0_ASW\\Mod2000\n"
"C:\\MyPath\\0_ASW\\Mod2005\\SubDir\n"
"C:\\MyPath\\10_BSW\\ModA\\SubDir\n"
"C:\\MyPath\\10_BSW\\ModB\n"
"C:\\MyPath\\10_BSW\\ModC\\\n"
"C:\\MyPath\\10_ASW\\ModC\\\n"
"C:\\MyPath\\nothing\\ModC\\\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")