import Foundation
let pattern = #"\\(?:0_ASW|10_BSW)\\(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\MyPath\0_ASW\Mod2000
C:\MyPath\0_ASW\Mod2005\SubDir
C:\MyPath\10_BSW\ModA\SubDir
C:\MyPath\10_BSW\ModB
C:\MyPath\10_BSW\ModC\
C:\MyPath\10_ASW\ModC\
C:\MyPath\nothing\ModC\
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)