# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Unit) \d+\w+/\1/gm;t' <<< "Start Unit 145C at Lunch Time"