$re = '/href="(https?:\/\/(?!mysite\.ru\/?).+?)"/m';
$str = '<a href="/onw">один</a>
<a href="/twoo">один</a>
<a href="#">три</a>
<a href="https://mysite.ru">четыр е</a>"
<a href="https://mysite.ru/news">пять</a>"
<a href="https://vk.com/feed">шесть</a>"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);