import Foundation
let pattern = #"href="(https?:\/\/(?!mysite\.ru\/?).+?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<a href="/onw">один</a>
<a href="/twoo">один</a>
<a href="#">три</a>
<a href="https://mysite.ru">четыре</a>"
<a href="https://mysite.ru/news">пять</a>"
<a href="https://vk.com/feed">шесть</a>"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)