$re = '/^\d*,MSH(?:[^|]*\|){9}\K[^|]*/m';
$str = '16037,MSH|^~\\&|SENDAPP|SENDFAC|RECVAPP|RECVFAC|1||ORU^R01|78455-874-6875|P|2.3|||AL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);