re = /^\d*,MSH(?:[^|]*\|){9}\K[^|]*/m
str = '16037,MSH|^~\\&|SENDAPP|SENDFAC|RECVAPP|RECVFAC|1||ORU^R01|78455-874-6875|P|2.3|||AL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end