#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<a[^>]*?href=(?|"([^"]*?)"|'([^']*?)').*?>(.*?)<\/a>"
Local $sString = "# Basic Cases" & @CRLF & _
"" & @CRLF & _
"<a href="http://test.com">double quotes</a>" & @CRLF & _
"" & @CRLF & _
"<a href='http://test.com'>single quotes</a>" & @CRLF & _
"" & @CRLF & _
"<a class="blah a href" data="blah" href="#rel-link" rel=''>complicated attributes</a>" & @CRLF & _
"" & @CRLF & _
"<a href="#anchor-1">adjacent</a><a href="#anchor-2">anchors</a>" & @CRLF & _
"" & @CRLF & _
"# Extra Cases" & @CRLF & _
"" & @CRLF & _
"<a href="http://test.com">title" & @CRLF & _
"linebreak</a>" & @CRLF & _
"" & @CRLF & _
"<a href="#anchor-reference"><span>inline span</span></a>" & @CRLF & _
"" & @CRLF & _
"<ahref="uri:test-uri">technically invalid anchor</a>" & @CRLF & _
"" & @CRLF & _
"<a href="http://test.com"><a href="#invalid">technically invalid internal anchor</a></a>" & @CRLF & _
"" & @CRLF & _
"<a href="'''''\"\"">quotes test</a>" & @CRLF & _
"" & @CRLF & _
"# Random Junk Stress Tests" & @CRLF & _
"" & @CRLF & _
"<a class="" href=""rergerger er erg><></><>.e.ewfe></wef/we. ></a>Test</a>" & @CRLF & _
"" & @CRLF & _
"<ahref="e">e</a>" & @CRLF & _
"" & @CRLF & _
"<a>e</a>" & @CRLF & _
"" & @CRLF & _
"<a href="">e<a href="">e</a></a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")