# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a[^>]*?href=(?|\"([^\"]*?)\"|'([^']*?)').*?>(.*?)<\/a>"
test_str = ("# Basic Cases\n\n"
"<a href=\"http://test.com\">double quotes</a>\n\n"
"<a href='http://test.com'>single quotes</a>\n\n"
"<a class=\"blah a href\" data=\"blah\" href=\"#rel-link\" rel=''>complicated attributes</a>\n\n"
"<a href=\"#anchor-1\">adjacent</a><a href=\"#anchor-2\">anchors</a>\n\n"
"# Extra Cases\n\n"
"<a href=\"http://test.com\">title\n"
"linebreak</a>\n\n"
"<a href=\"#anchor-reference\"><span>inline span</span></a>\n\n"
"<ahref=\"uri:test-uri\">technically invalid anchor</a>\n\n"
"<a href=\"http://test.com\"><a href=\"#invalid\">technically invalid internal anchor</a></a>\n\n"
"<a href=\"'''''\\\"\\\"\">quotes test</a>\n\n"
"# Random Junk Stress Tests\n\n"
"<a class=\"\" href=\"\"rergerger er erg><></><>.e.ewfe></wef/we. ></a>Test</a>\n\n"
"<ahref=\"e\">e</a>\n\n"
"<a>e</a>\n\n"
"<a href=\"\">e<a href=\"\">e</a></a>\n")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.