package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`id=(\d+)*`)
var str = `There are three ids: id=10 and id=12 and id=100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}