$re = '/id=(\d+)*/';
$str = 'There are three ids: id=10 and id=12 and id=100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);