import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(youtu\\.be\\/|youtube(-nocookie)?.com\\/(v\\/|e\\/|.*u\\/\\w+\\/|embed\\/|.*v=))([\\w-]{11})";
final String string = "http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg\n"
+ "http://youtu.be/0zM3nApSvMg\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o\n\n"
+ "_http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "_http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
+ "_http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "_http://www.youtube.com/watch?v=0zM3nApSvMg\n"
+ "_http://youtu.be/0zM3nApSvMg\n"
+ "_http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "_http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/KdwsulMb8EQ\n"
+ "_http://youtu.be/dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/embed/dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/v/dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/e/dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/watch?v=dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/?v=dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "_http://www.youtube.com/user/IngridMichaelsonVEVO#p/u/11/KdwsulMb8EQ\n"
+ "_http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0\n\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=y_Rd2hByRyc\n\n"
+ "v/2059-9080-5437";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}