re = /(youtu\.be\/|youtube(-nocookie)?.com\/(v\/|e\/|.*u\/\w+\/|embed\/|.*v=))([\w-]{11})/
str = 'http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0
http://www.youtube.com/embed/0zM3nApSvMg?rel=0
http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index
http://www.youtube.com/watch?v=0zM3nApSvMg
http://youtu.be/0zM3nApSvMg
http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s
http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o
_http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0
_http://www.youtube.com/embed/0zM3nApSvMg?rel=0
_http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index
_http://www.youtube.com/watch?v=0zM3nApSvMg
_http://youtu.be/0zM3nApSvMg
_http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s
_http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/KdwsulMb8EQ
_http://youtu.be/dQw4w9WgXcQ
_http://www.youtube.com/embed/dQw4w9WgXcQ
_http://www.youtube.com/v/dQw4w9WgXcQ
_http://www.youtube.com/e/dQw4w9WgXcQ
_http://www.youtube.com/watch?v=dQw4w9WgXcQ
_http://www.youtube.com/?v=dQw4w9WgXcQ
_http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ
_http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ
_http://www.youtube.com/user/IngridMichaelsonVEVO#p/u/11/KdwsulMb8EQ
_http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0
http://www.youtube.com/watch?feature=player_embedded&v=y_Rd2hByRyc
v/2059-9080-5437'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end