using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(interface GigabitEthernet.*)(?:(?!interface GigabitEthernet)[\s\S])*switchport mode access";
string input = @"interface GigabitEthernet1/0/1
description abc
bla
switchport mode access
xyz
abc
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
xyz
abc
interface GigabitEthernet1/0/4
description Test
switchport mode access
xyz
abc
interface GigabitEthernet1/0/5
description
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}