re = /(interface GigabitEthernet.*)(?:(?!interface GigabitEthernet)[\s\S])*switchport mode access/m
str = 'interface GigabitEthernet1/0/1
description abc
bla
switchport mode access
xyz
abc
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
xyz
abc
interface GigabitEthernet1/0/4
description Test
switchport mode access
xyz
abc
interface GigabitEthernet1/0/5
description
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end