import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[gif|jpg|jpeg|png|webp|avif]+(,[gif|jpg|jpeg|png|webp|avif]+)*$";
final String string = "gif jpg jpeg png webp avif\n"
+ "gif,jpg,jpeg,png,webp,avif\n"
+ "gif,jpg,jpeg,png,webp,avif,\n"
+ "gif,jpg,jpeg,png,webp,avif,ico\n"
+ "gif,jpg,jpeg,png,psd\n"
+ "gif,jpg,jpeg,png\n"
+ "gif,jpg,jpeg,png,xml\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}