$re = '/^[gif|jpg|jpeg|png|webp|avif]+(,[gif|jpg|jpeg|png|webp|avif]+)*$/m';
$str = 'gif jpg jpeg png webp avif
gif,jpg,jpeg,png,webp,avif
gif,jpg,jpeg,png,webp,avif,
gif,jpg,jpeg,png,webp,avif,ico
gif,jpg,jpeg,png,psd
gif,jpg,jpeg,png
gif,jpg,jpeg,png,xml
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);