$re = '/^[7][13478]263[0-9]{9}$/';
$str = '78263123456987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);