$re = '/(location=)(.*)(%2C%20TX)/';
$str = '\'https://www.airbnb.com/rooms/18520444?location=Cleveland%2C%20TX\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);