// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(location=)(.*)(%2C%20TX)").unwrap();
let string = "'https://www.airbnb.com/rooms/18520444?location=Cleveland%2C%20TX'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}