$re = '/^(?!.*(?:session|curl)).*Dec/m';
$str = 'session Dec Line 1
session Rec Line 2
Current: Dec Line 3
curl Dec Line 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);