re = /^(?!.*(?:session|curl)).*Dec/m
str = 'session Dec Line 1
session Rec Line 2
Current: Dec Line 3
curl Dec Line 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end