$re = '/\b100\$(?=\s|\$)/m';
$str = 'I found 100$ buried in the backyard.
I only have $100.
Here 100$blah blah blah.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);