re = /\b100\$(?=\s|\$)/m
str = 'I found 100$ buried in the backyard.
I only have $100.
Here 100$blah blah blah.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end