using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[authis\](.*?)(\[else\](.*?))?\[\/authis\]";
string input = @"abc[authis]def[else]ghi[/authis]jkl
mno[authis]pqr[/authis]stu";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}