$re = '/\[authis\](.*?)(\[else\](.*?))?\[\/authis\]/si';
$str = 'abc[authis]def[else]ghi[/authis]jkl
mno[authis]pqr[/authis]stu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);