use strict;
my $str = 'Fri Feb 24 23:45:52 2023","San Francisco->San Francisco->SFO-Servers","Default Department","San Francisco->San Francisco->SFO-Servers","53","53544","53","39474","172.17.129.110","156.154.71.5","104.129.192.104","128.177.129.156","157.130.202.234","0","GRE","Allow","Yes","Yes","No","DNS","dns","UDP","Miscellaneous or Unknown","United States","1","Default Allow","143","86","0","1","1","None","None","None","NA","NA"';
my $regex = qr/\d+:\d+\s+(?:.*?",")(?<user>[^"]+)(?:.*?",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<src>[^"]+)(?:",")(?<dst>[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<action>[^"]+)(?:.*?",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<svc>[^"]+)(?:.*?",")(?<application>[^"]+)(?:.*?",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?:[^"]+)(?:",")(?<ruleName>[^"]+)(?:.*?",")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}