const regex = /(p\.fg|pfg|p\.f) \d{11}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(p\\.fg|pfg|p\\.f) \\d{11}', 'g')
const str = `p.fg 67389109321
pfg 67389109321
p.f 67389109321`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}