$re = '/(p\.fg|pfg|p\.f) \d{11}/';
$str = 'p.fg 67389109321
pfg 67389109321
p.f 67389109321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);