re = /(?!\bbar\b)\b[A-Za-z-]*bar[a-z-]*\b/
str = 'Belly up to the bar boys but watch
out for that barrel.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end