$re = '/-([0-9.-]*)-/';
$str = 'num-12345678-num
num-12345678-234-213-num
X-8551-03-24-13.20.29.709622-Z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);