re = /-([0-9.-]*)-/
str = 'num-12345678-num
num-12345678-234-213-num
X-8551-03-24-13.20.29.709622-Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end