import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(([\\d\\p{L}\\-_$&+:;=?@#|!\\.]+ )*[\\d\\p{L}\\-_$&+:;=?@#|!\\.]+)++,)*+(([\\d\\p{L}\\-_$&+:;=?@#|!\\.]+ )*[\\d\\p{L}\\-_$&+:;=?@#|!\\.]+)++$";
final String string = "1,2\n"
+ "1 1,2\n"
+ "a@b.com,a\n\n\n"
+ "1,\n"
+ ",1\n"
+ "1,,2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}