re = /^(?:(([\d\p{L}\-_$&+:;=?@#|!\.]+ )*[\d\p{L}\-_$&+:;=?@#|!\.]+)++,)*+(([\d\p{L}\-_$&+:;=?@#|!\.]+ )*[\d\p{L}\-_$&+:;=?@#|!\.]+)++$/m
str = '1,2
1 1,2
a@b.com,a
1,
,1
1,,2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end