package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[img\](.*?)xyz_zyx_abc(.*?)\[\/img\]`)
var str = `Test
[img]http://localhost/verz123/xyz_zyx_abc/70-300mm_IS_II_USM 331.jpg[/img]
test
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}