$re = '/\[img\](.*?)xyz_zyx_abc(.*?)\[\/img\]/';
$str = 'Test
[img]http://localhost/verz123/xyz_zyx_abc/70-300mm_IS_II_USM 331.jpg[/img]
test
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);