#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^a-zA-Z]+|^)woc([^a-zA-Z]+|$)"
Local $sString = "1woc2" & @CRLF & _
"woc" & @CRLF & _
"woc3a" & @CRLF & _
"1woc" & @CRLF & _
"wock" & @CRLF & _
"qwoc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")