$re = '/([^a-zA-Z]+|^)woc([^a-zA-Z]+|$)/m';
$str = '1woc2
woc
woc3a
1woc
wock
qwoc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);