const regex = /^([A-Z0-9])(?!(\1|&)+$)(?=.{11,13}$)[A-Z0-9]*(?:[&][A-Z0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z0-9])(?!(\\1|&)+$)(?=.{11,13}$)[A-Z0-9]*(?:[&][A-Z0-9]+)?$', 'gm')
const str = `allowed
111111111112
1111111&11112
125478&563254
ABC123567GHDG4
ABC1235&67GHD
ABCDEFGHIJKLR
1254789563254
125478&563254
not allowed
1111111&11111
125478556325&
&ABCDEFGHIJKL
&125478556325
ABCDEFGHIJKL&
&ABCDEFGHIJKL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}